Tuesday, 20 December 2011

Toshiba Satellite U400 lights always on

A member of staff brought in their laptop which I'd fixed just the other day (they'd accidentally switched the wireless off). She was saying how the lights for the "soft keys" at the top of the keyboard were always on.

I thought this wasn't so much of a problem, but actually it probably wouldn't be too good wasting the battery so much. I looked into it. At first I thought it was set up through the BIOS. I found an "Illumition" setting mentioned in this post so I had a look. I switched it off. This had no effect though.

My next guess was to look into windows and the many Toshiba apps that they put on. These were all rubbish but found one which let you change the same setting in the BIOS.

I found it mentioned that it might be due to a Microsoft Update so I took it through System Restore to undo all the updates. This didn't have any effect either.

Finally I thought of taking the battery out and putting it back in (just to see what it looked like with the buttons not light up). Once I'd put the battery back in, the lights didn't light up. In fact they'd stopped lighting up altogether!

I rebooted a few times and it looks like it worked. I even turned on "Illumination" and the lights came back on. And on switching it off they turned off, beautiful.

So in conclusion. Just take the battery out and put it back in again. Also disconnect from power source.



Printing on the Epson Stylus Pro 7600

It is best to work from a ready-made local login on this machine:

Username: Print
Password: print

Load your picture up into Photoshop. You need to make sure it is the right size so in the menu's, slelect Image > Image Size. You can change the height or width to what you want.
Photoshop's "Image Size" dialogue box
Now you can go to - File > Print
  1. Select the printer named: N239 - Epson Stylus Pro 7600
  2. Click on the Page setup and select the right page size (for roll select Super A1) or create a Custom Paper Size (see next image)
  3. Click on the orientation of the page
  4. Change the size of the picture by dragging the corners or using the numbers
  5. Click on Print to get to the next dialogue box
Photoshop's "Print" dialogue box
  1. Select the printer named: N239 - Epson Stylus Pro 7600
  2. Select the right Paper Size. If it is not in the list create a custom paper size (see next image)
  3. Change the "Copies and Pages" option to "Print Settings"
  4. Change the "Media Type" to the appropriate setting
  5. Change Print Quality to "Superfine - 1440"
  6. Click "Save" to print, BUT check the printer is OK first (next image)

Epson Stylus Pro 7600 print dialogue box
  1. To make a new custom paper size click the "+"
  2. If you're printing on the A1+ roll paper make sure the width is 61.55 cm
  3. Name it something appropriate
  4. Click OK once the Paper Size is right 
OS X "Custom Paper Sizes" dialogue box
  1. Switch it on
  2. Check it is on either "Roll with Autocut" or "Sheet" depending upon what you are printing on
  3. Release the handle and fee paper in
  4. Make sure it is straight and then close the handle
  5. Press the Pause button if asked
It should now feed the paper through and check out if its straight. If you get an error message, feed the sheet in again , double checking if it's straight.

Epson Stylus Pro 7600 panel instructions

Now, if it starts printing something and you haven't sent anything to print it is probably someone else's print, in which case hold the Pause button for 3 seconds that should cancel the job. Also check the print queue by clicking on the print shortcut at the bottom of the screen.

When you're sure everything is good, on the computer - press PRINT

Monday, 19 December 2011

CD and DVD drives "Device cannot start" error 10 in device manger - Windows

A member of staff brought in their PC today saying that the DVD drives (there are two) don't work.

Looking in Device manager I found that both DVD drives were down as CD drives and in the details it says something along the lines of:
The device cannot start error 10

My first idea was to do with Master and Slave jumper switches on the back of the DVD drives. Tried all the combinations. For some the drives came up as their actual names, but still came up with the error message.

After this I did a system restore to its' earliest point. Still no luck.

I finally thought it had to do with iTunes. I've experienced it before, when installing iTunes the CD drive stops working in Windows. I had a search around on google and found this forum. It seemed promising and pointed towards this Microsoft troubleshooting guide.

Also, another tutorial is here from Apple who admit the problem.

Although this was to do with Windows XP and error 31 I found other forums mentioning the registry and "Upper Filters" and "Lower Filters". I deleted the UpperFilter registry entry mentioned and it worked a treat.


  1. load up Regedit by going to Start > Run > Regedit
  2. go to:
    1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
  3. delete the UpperFilter, usually at the bottom
  4. Reboot the machine

Friday, 16 December 2011

Upgrading and imaging iPads (or any IOS device)

Thought I'd document the technique I use for managing the iPads in an Academic environment.

Using this technique you can backup an iPad and restore it to all your other iPads.

A point to note is that you cannot restore an IOS 5 "Backup" onto an IOS 4 iPad. You will need to manually update the iPad to IOS 5 first.

Right click (or CTRL click) on the IOS device on the list on the left

Create an image from a "Master" iPad (called "backup")

  1. Get your iPad exactly how you want it
  2. Plug it into iTunes
  3. Right click on the IOS device in the list on the left
  4. Click "Backup"
Restore an image onto IOS device
  1. Plug IOS device in to iTunes 
  2. Plug it into iTunes
  3. Right click on the IOS device in the list on the left
  4. Click "Restore from Backup"
If the IOS version is the same, it should list all the "Backups" or images that have been taken. Select the one you want.

Thursday, 15 December 2011

Scanning on the Canon LiDE 60 Scanner on OS X 10.6

Go to Applications > Image Capture

1. Click on the scanner in the top left
2. Click "Show Details"
3. Check that the details are correct (300 dpi is good)
4. Click "Scan"

Installing Canon LiDE 60 scanner on OS X 10.6.6

I recently updated one of the PC's to an iMac, yay, but forgot to think about the scanner attached. It was a Canon LiDE 60 scanner. The mac had OS X 10.6.6. Tried "Image Capture" at the off chance it'd pick it up straight away and alas it did not.

I did a quick search on the internet and found this bit of info. It says you have to install two things, a driver and something else (didn't pay too much attention). A lot of people agreed with it.

I went to Canons website, found the downloads section for the scanner here and downloaded all the OS X stuff. I was a little annoyed that it does not have a description of any of the downloads. I would like to know what they actually are.

After I downloaded it I started off trying the driver called "deldrvosx1510efg.dmg". Looked good to begin with but then asked if I was sure I wanted to uninstall the Canon LiDE 60 scanner! After saying yes (didn't think it would do any harm) it crashed.

I next tried the "lide60osx11131en.dmg" which contained the "ScanGear CS 11.1 Eng_Installer.pkg" file. It was quick and painless and wanted a reboot. After the reboot I loaded up Image Capture and it worked a treat!

So, to conclude, you basically just need to install the ScanGear CS pkg file.


Wednesday, 14 December 2011

Jailbreaking iPhone 3GS with IOS 5.0.1

So, I've just got an iPhone 3GS which is locked to o2. The form has been filled out, and it'll take between 1 and 2 weeks. So I can either wait, or jailbreak! (that rhymes!)

Found this lovely website which goes into every detail of jailbreaking lots of things including iPhone 3GS with IOS 5.0.1.

A big thing to note is that if your iPhone every looses power, you will need redsn0w to reboot it (i think that means that you'll need your computer too!). This is a BIG problem, and hence forth I shall not Jailbreak my phone!!!!

Tuesday, 13 December 2011

Mac Pro startup trouble - White screen with no entry sign

On start up, mac makes startup noise, goes to white screen with Apple Logo and spinny thing at bottom, then after about 2 minutes the Apple Logo changes to a grey No Entry sign. Still the spinny thing at the bottom.

I've tried:

  • reset PRAM/NVRAM (same thing)
  • holding down "alt" and selecting Windows partition boots to windows perfectly!
  • single user mode
    • comes up with "Still waiting for Root Device"
  • netboot - using deploy studio
    • repair disk permissions is Disk Utility
    • set startup disk to OS X
  • reimage OS X

Found this apple article, although it's dated back to 10.1, and 10.2! Goes on about reseting PRAM, reinstall OS.

Finally, I thought I would try the Hard Drive on another machine, so I "firewired" it up to the machine next to it.

  • I booted the broken one off the working one. Worked fine
  • I booted the working one off the broken one. Worked fine
So I knew that both installations on both Hard Drives worked fine. To boot I held down "alt" and selected the firewire OSX to boot from. It appeared that using the "alt" key to select an operating system fixed the problem.

I then tried holding down the "alt" button, selected the OS X partition which wasn't working, and it worked fine!!

So, I finally concluded that it was down to the "bless" command you use. The one with Deploy Studio (which is how I set the boot disk originally) seems to not work with this machine.

So, to fix this:
  1. I booted the machine on it's normal OS X partition (holding down "alt" to select the OS X partition)
  2. Went into "System Preferences" and "Startup Disk"
  3. Selected first the Windows Partition, and then the OS X partition
This hopefully set the "bless" command right again.

It worked!!

Monday, 12 December 2011

Unable to download IOS 5 software update through iTunes

I'm in the process of updating the iPads to IOS 5, but I'm stuck at the first stumbling block. I need to download the iPad update file. Whenever I click the update button through iTunes it starts to download the file, but a few minutes later it says:

There was a problem downloading the software for the iPad. Then network connection timed out
I found the file location it was downloading it to is:

/Library/iTunes/iPad\ Software\ Updates/iPad1,1_5.0.1_9A405_Restore.ipsw

It downloads approx 100MB, but this varies and then comes up with the error message. After a bit of searching I found this website which gives you direct links to the ipsw update files, straight from what looks like the apple download server. I've also found this website as well

Download location is for the iPad 1st gen is:

Download location for the iPad 2 - Wifi is:

Interestingly, after attempting this with Safari it also failed. I'm guessing it has to do with the proxy server we're using. I shall try another.

Finally downloaded it through another computer connected to a different proxy. Worked fine. Final file was approx. 750MB.

Loaded up iTunes, "alt" clicked the "Update" button and selected the downloaded file. Worked fine.

We're now on 5.1.1. Heres the link to the IOS update:

iPad 1

iTunes iPad backup location

I've noticed my Library folder get immensely large. I looked into it with OmnDiskSweeper (now that WhatSize has decided to charge) and found nearly 800MB (not much nowadays but too much for this as far as ICT Services goes) was taken up with iPad backups:

/Library/Application\ Support/MobileSync/Backup

I thought the easiest solution was to move it to the local scratch disk and symbolically link it. Heres the exact command I used to create the symbolic link:

ln -s /Volumes/Scratch\ Disk/Stephen/Library/Application\ Support/MobileSync/Backup /Network/Servers/appleton.chesterfield.ac.uk/home2\$/LeachS/Library/Application\ Support/MobileSync 

Seems to have done the trick.

I also noticed another folder taking up a lot of disk space whenever I tried to do a software update for the iPads:

/Volumes/Scratch\ Disk/Stephen/Library/iTunes/iPad Software Updates/

I decided to move the whole /Library/iTunes folder across. Here's the command I used to create a symbolic link:

ln -s /Volumes/Scratch\ Disk/Stephen/Library/iTunes /Network/Servers/appleton.chesterfield.ac.uk/home2\$/LeachS/Library

Internet Explorer desktop icon makes more Internet Explorer shortcuts on the desktop!

An interesting problem occured today. I was just going to browse the internet on an XP laptop using Internet Explorer when I noticed that whenever I clicked on the desktop shortcut for IE, IE wouldn't load up but a new "Shortcut to Internet Explorer" would pop up on the desktop. Clicking on the shortcut in the Start menu did not do the same, but would come up with the "Don't Send" option because IE had crashed.

I looked up the problem on the internet and found this. At the bottom it describes the fix for it. Which is some Regedit stuff plus a bit more.

I decided that it was worth trying to update IE first. Updated from IE 6 to IE 8 and worked a treat.

Photoshop CS 5 "Document was made in a newer version" work-around

I've just had a student struggling to open a photoshop file. The "error" that came up was something along the lines of:
Cannot open document as it was made in a newer version

This was not the case though, as the student had only ever used that computer to make the file. I checked his disk space of which he had 50MB free, and the photoshop file was 90MB. It could have been caused by a lack of disk space.

You could see OS X making a nice little preview of the file, and so I decided to try and open it using Preview (which does now open new PSD files). I opened perfectly in Preview and I selected "Save As" from Preview and saved it as another PSD file.

This opened without trouble in Photoshop, but I did notice it didn't have any layers. I did not ask the student if this was how he had made it, but I think it should have had layers. My conclusion is that Preview, upon saving, merges the layers. I'm also assuming that the PSD file was originally saved for "maximum compatibility" which saves a merged layer.

So, in ultimate conclusion, always "save with maximum compatibility" in Photoshop. This way you might have a better chance opening a "broken" file in Preview and saving it out of this.