Tuesday, 28 August 2012

iTunes requires Quicktime 7.5.5 on OS X 10.5.8

After updating a G4 PowerBook to OS X 10.5.8, making sure all the software was up to date with "Software Updates" in the Apple Menu, I tried iTunes. It came up with the error message:
iTunes requires Quicktime 7.5.5

I had a quick look around and found this in Apple Discussions. It appears Software Update does not pick up on the quicktime update. If you go to  http://support.apple.com/downloads/#quicktime it gives you a list of quicktime downloads. The latest version at present which goes on OS X 10.5.8 is Quicktime 7.7

After downloading and installing it's working fine.


  1. Thanks for posting this. I had a total mess too, going from a powerbook G4 to an intel imac. I was on the verge of madness.

    Have a good one and keep the good work. It is helpful!

  2. The link in your article wasn't working, so here's a link directly to quicktime 7.7: