Wednesday, 27 July 2011

OS X 10.6.6 Active Directory login Dreamweaver doesn't load

On trying to load Dreamweaver up on an Active Directory account running OS X 10.6.6 Dreamweaver trys to load but stops almost straight away with no error! It still runs but doesn't even load a splash screen. When logging in on a local account Dreamweaver works a charm.

A quick search drew up a few posts, heres an example. Most point to permissions issues on the "Configuration" folder in /Library/Application\ Support/Adobe/Dreamweaver CS5. This was mainly caused by FileVault which is obviously more common then people using Active Directory logins. The only solution of which is to switch FileVault off! Of course we can't just switch off Active Directory logins though!

I do have NHR installed, and with the Caches folder being relocated to the local drive I know it is not this. I figured it might be another folder dreamweaver tries to use. Here are the other files:

  • /Library/Application\ Support/Adobe/Dreamweaver\ CS5
  • /Library/Preferences/Adobe\ Dreamweaver\ CS5\ Prefs
there's also a plist file in the Preferences folder but I deleted it and it has not been recreated. Something like


I've also been having a few issues with the Application Support folder, which occasionally doesn't let me write files or folders to it, which causes problems like these. I originally thought it was this which caused the problem, but since rebooting I can now access the App support folder and dreamweaver still doesn't work.

Just playing around with NHR. I've adapted the script so that it creates a symlink for /Application Support/Adobe rather then some of the folders inside. Should be simpler. Didn't solve the problem though.

An error does keep appearing which is related to the file used in /Library/Preferences. Called:

Adobe Dreamweaver CS5 Prefs

Whenever I load Dreamweaver up (or try to) this appears in Console

27/07/2011 14:04:59 Finder[2463] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.

I've tried to create an alias of this file on the local hard drive which doesn't seem to make any difference. My only guess is this always comes up.

I shall endevour to locate any other files Dreamweaver may use. Upon loading dreamweaver on a local login I found a lot more files in the Configuration folder in Application Support. I also found that the "Adobe Dreamweaver CS5 Prefs" file had more text in, so I copied these over to the networked account to see if it would change anything. Nope.

If anyone has any other information I would be glad to here it. I'm going to have to revert to a local account to use Dreamweaver until then!!

Well, what do you know. I updated from Dreamweaver version 11.0.0 to using AdobeDreamweaver-11.0-All-Update.dmg. Seems to work nicely now, I see a splash screen and next it tells me Adobe Extension Manager needs to load to finish the update.
Of course now this "Extension Manager" has the same problem DreamWeaver had. It just pops up and sits there not doing anything. But it does let Dreamweaver finish loading and lets me use Dreamweaver. The only real downside is that I get this message every time I load dreamweaver.

I'll try loading this up using a local account, maybe it updates files on the Hard Drive, or maybe it updates files on the Users Home Drive?

1 comment:

  1. I can't believe it, but it happened again! And on the same computer I'd updated. So on version 11.0.3 it hung on the splash screen! I was quite frustrated.

    After a few minutes I'd updated again to 11.0.4, but it still hung. Next was to delete all preferences in my home. FIXED IT!!

    It now works again, but a little frustrating none-the-less.