Friday, 22 February 2013

Workgroup Manager Crashing on connecting to server

Recently I've had an issue with Workgroup Manager crashing when it connects to the Xserver:

Error of type eMemoryAllocError (-14901) on line 401 of /SourceCache/WorkgroupManager/WorkgroupManager-361.3.1/DirNodeRefController.m
Please not I'm using:

  • Workgroup Manager Version 10.6.3 (361.3.1)
  • OS X 10.6.8
  • OS X Server 10.4.11

Doing a copy and paste in google brings up on 1 result which happens to be on Apple Discussions.  The discussion is exactly what I was looking for. Here it is.

Basically they describe the problem after a security update (not sure whether it was on the client or server). Luckily there is a work-around by ManuelSF, but people are not really liking it. Here it is:

  1. open workgroup manager
  2. click cancel at the login screen
  3. go to server in the menu bar and select view directories
  4. you should see your directory
  5. click on the lock in the upper left-hand corner to unlock and edit the directory.
Works better then it did before surprisingly!

1 comment:

  1. Ugh. cls36 from the same forum filed a bug report on this issue in September, and apparently the engineering team got back to him last April with this:

    Apple Developer Bug Reporting Team :
    Thanks very much for the feedback.

    Engineering has determined that this is not to be fixed.

    We are now closing this bug report.

    If you have questions regarding the resolution of this issue, please
    update your bug report with them.

    Thanks, Apple. Guess we'll just have to think different.